blob: 5c9025fbb6790b3dbf331a0ed9fa888e2efe1268 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "VA-API support to GStreamer"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05002HOMEPAGE = "https://gstreamer.freedesktop.org/"
Andrew Geissler82c905d2020-04-13 13:39:40 -05003DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
4based plugins for GStreamer and helper libraries: `vaapidecode', \
5`vaapiconvert', and `vaapisink'."
6
7REALPN = "gstreamer-vaapi"
8
9LICENSE = "LGPLv2.1+"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
Andrew Geissler6ce62a22020-11-30 19:58:47 -060012SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
Andrew Geissler95ac1b82021-03-31 14:34:31 -050014SRC_URI[sha256sum] = "92db98af86f3150d429c9ab17e88d2364f9c07a140c8f445ed739e8f10252aea"
Andrew Geissler82c905d2020-04-13 13:39:40 -050015
16S = "${WORKDIR}/${REALPN}-${PV}"
17DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
Andrew Geissler6ce62a22020-11-30 19:58:47 -060019inherit meson pkgconfig features_check upstream-version-is-even
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21REQUIRED_DISTRO_FEATURES ?= "opengl"
22
23EXTRA_OEMESON += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060024 -Ddoc=disabled \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 -Dexamples=disabled \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060026 -Dtests=enabled \
Andrew Geissler82c905d2020-04-13 13:39:40 -050027"
28
Andrew Geissler82c905d2020-04-13 13:39:40 -050029PACKAGES =+ "${PN}-tests"
30
31# OpenGL packageconfig factored out to make it easy for distros
32# and BSP layers to pick either glx, egl, or no GL. By default,
33# try detecting X11 first, and if found (with OpenGL), use GLX,
34# otherwise try to check if EGL can be used.
35PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
36 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
37 '', d), d)}"
38
39PACKAGECONFIG ??= "drm encoders \
40 ${PACKAGECONFIG_GL} \
41 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
42
43PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
44PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
45PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
46PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
47PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
48PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
49
Patrick Williams213cb262021-08-07 19:21:33 -050050FILES:${PN} += "${libdir}/gstreamer-*/*.so"
51FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug"
52FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a"
53FILES:${PN}-tests = "${bindir}/*"