blob: eba53e728d1e479f2edfe2c4a22ef5a8f0ef1a68 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "It extracts messages from XML files and outputs PO template \
3files, then merges translations from MO files to create translated \
4XML files. It determines what to translate and how to chunk it into \
5messages using the W3C Internationalization Tag Set (ITS). "
Andrew Geissler82c905d2020-04-13 13:39:40 -05006HOMEPAGE = "http://itstool.org/"
7LICENSE = "GPLv3"
8LIC_FILES_CHKSUM = "file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5"
9
10inherit autotools python3native
11
12DEPENDS = "libxml2-native"
13
14SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2"
Patrick Williams213cb262021-08-07 19:21:33 -050015SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
16SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
17SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
19SRC_URI[md5sum] = "4306eeba4f4aee6b393d14f9c3c57ca1"
20SRC_URI[sha256sum] = "6233cc22726a9a5a83664bf67d1af79549a298c23185d926c3677afa917b92a9"
21
22BBCLASSEXTEND = "native nativesdk"
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += "libxml2-python"