blob: ae30a7a1001b42426b2876fe9b3337e62cb20f24 [file] [log] [blame]
Andrew Geissler90fd73c2021-03-05 15:25:55 -06001SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5b002a195fb7ea2d8d583f07eaff3a8e"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt libpcre2"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v1.1"
Andrew Geissler5f350902021-07-23 13:09:54 -04009SRCREV = "8a0dc6783c340e61a44c179c48f832165ad2053c"
Andrew Geissler90fd73c2021-03-05 15:25:55 -060010
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DBUILD_CLAR=OFF \
17 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
18 -DLIB_INSTALL_DIR=${libdir} \
19 -DREGEX_BACKEND='pcre2' \
20"
21
22BBCLASSEXTEND = "native"