blob: 57ddc666b8875bd904caf98e78df1df60720d6e7 [file] [log] [blame]
Lancelot Kao96a7ee32021-02-22 18:50:48 -06001SUMMARY = "Phosphor OpenBMC Kudo System Power Control Service"
2DESCRIPTION = "Phosphor OpenBMC Kudo System Power Control Daemon"
3
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
7
8inherit systemd
9inherit obmc-phosphor-systemd
10
11DEPENDS += "systemd"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050012RDEPENDS:${PN} += "libsystemd"
13RDEPENDS:${PN} += "bash"
Lancelot Kao96a7ee32021-02-22 18:50:48 -060014
XP Chen9b906962021-05-06 15:23:19 -050015SRC_URI = " \
Lancelot Kao96a7ee32021-02-22 18:50:48 -060016 file://init_once.sh \
17 file://host-powerctrl.service \
18 "
19
20SYSTEMD_PACKAGES = "${PN}"
Mohaimen Alsamaraif59d0172021-08-17 09:34:22 -050021SYSTEMD_SERVICE:${PN} = " \
Lancelot Kao96a7ee32021-02-22 18:50:48 -060022 host-powerctrl.service \
23 "
24
25do_install () {
Charles Boyer2adad362021-11-24 15:58:03 -060026 install -d ${D}${libexecdir}/${PN}
27 install -m 0755 ${WORKDIR}/init_once.sh ${D}${libexecdir}/${PN}/init_once.sh
Lancelot Kao96a7ee32021-02-22 18:50:48 -060028 install -d ${D}${systemd_unitdir}/system/
29 install -m 0644 ${WORKDIR}/host-powerctrl.service ${D}${systemd_unitdir}/system
30}