blob: 770ffeafda22230a02f59ea14159b641dc4abdbe [file] [log] [blame]
Brad Bishopf61a81a2019-02-04 14:28:33 -05001FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += " file://pam.d/common-password \
4 file://pam.d/common-account \
5 file://pam.d/common-auth \
Richard Marian Thomaiyar2b597052019-11-02 21:24:29 +05306 file://pam.d/common-session \
Brad Bishopf61a81a2019-02-04 14:28:33 -05007 "
8
9RDEPENDS_${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \
10 ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \
11 ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \
12 "
13
Matt Spinler31ab8e72018-10-16 11:32:13 -050014do_install_append() {
15 # The libpam recipe will always add a pam_systemd.so line to
16 # common-session if systemd is enabled; however systemd only
17 # builds pam_systemd.so if logind is enabled, and we disable
18 # that package. So, remove the pam_systemd.so line here.
19 sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session
20}