blob: 90a1a9bd9bb1ee25b9222703b7c0c8a6e4a9fe19 [file] [log] [blame]
Brad Bishopb1e88402017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop4186efb2017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
10SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishopb1e88402017-01-11 11:12:32 -050011
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "sdbusplus"
14
15RDEPENDS_${PN} += "\
16 libsystemd \
17 "
18
19SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop4186efb2017-01-11 15:30:07 -050020SRC_URI += "file://70-hwmon.rules"
Brad Bishopb1e88402017-01-11 11:12:32 -050021
22SRCREV = "8d89325adccbf7616e34210bb15ec3bebe17fcfe"
23
24S = "${WORKDIR}/git"
Brad Bishop4186efb2017-01-11 15:30:07 -050025
26do_install_append() {
27
Brad Bishop2b9921e2017-01-26 09:12:57 -050028 install -d ${D}/${base_libdir}/udev/rules.d/
29 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brad Bishop4186efb2017-01-11 15:30:07 -050030}