Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Advanced tools for certain ALSA sound card drivers" |
| 2 | HOMEPAGE = "http://www.alsa-project.org" |
| 3 | BUGTRACKER = "https://bugtrack.alsa-project.org/alsa-bug/login_page.php" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2 & LGPLv2+" |
| 6 | DEPENDS = "alsa-lib ncurses glib-2.0" |
| 7 | |
| 8 | LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 9 | file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 10 | |
| 11 | SRC_URI = "ftp://ftp.alsa-project.org/pub/tools/${BP}.tar.bz2 \ |
| 12 | file://autotools.patch \ |
| 13 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', \ |
| 14 | 'file://makefile_no_gtk.patch', d)} \ |
| 15 | file://gitcompile_hdajacksensetest \ |
| 16 | file://0001-as10k1-Make-output_tram_line-static-inline.patch \ |
| 17 | " |
| 18 | |
| 19 | SRC_URI[md5sum] = "f339a3cd24f748c9d007bdff0e98775b" |
| 20 | SRC_URI[sha256sum] = "94abf0ab5a73f0710c70d4fb3dc1003af5bae2d2ed721d59d245b41ad0f2fbd1" |
| 21 | |
| 22 | inherit autotools-brokensep pkgconfig |
| 23 | |
| 24 | CLEANBROKEN = "1" |
| 25 | |
| 26 | EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}'" |
| 27 | |
| 28 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk+', '', d)}" |
| 29 | PACKAGECONFIG[gtk+] = ",,gtk+ gtk+3," |
| 30 | |
| 31 | # configure.ac/.in doesn't exist so force copy |
| 32 | AUTOTOOLS_COPYACLOCAL = "1" |
| 33 | |
| 34 | do_compile_prepend () { |
| 35 | #Automake dir is not correctly detected in cross compilation case |
| 36 | export AUTOMAKE_DIR="$(automake --print-libdir)" |
| 37 | export ACLOCAL_FLAGS="--system-acdir=${ACLOCALDIR}/" |
| 38 | |
| 39 | cp ${WORKDIR}/gitcompile_hdajacksensetest ${S}/hdajacksensetest/gitcompile |
| 40 | } |
| 41 | |
| 42 | FILES_${PN} += "${datadir}/ld10k1" |