blob: 923227971d502e48052853305d757bdf218c2e24 [file] [log] [blame]
Ratan Gupta3aa591f2017-03-06 17:05:11 +05301SUMMARY = "Sensor config for phosphor-host-ipmi"
2PR = "r1"
Brad Bishop75f03872018-11-03 09:41:57 -07003LICENSE = "Apache-2.0"
Brad Bishop6f3f0aa2019-09-13 12:14:05 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Ratan Gupta3aa591f2017-03-06 17:05:11 +05305
Ratan Gupta3aa591f2017-03-06 17:05:11 +05306inherit phosphor-ipmi-host
Joseph Reynolds79809ea2021-02-26 15:37:31 -06007inherit native
Ratan Gupta3aa591f2017-03-06 17:05:11 +05308
9PROVIDES += "virtual/phosphor-ipmi-sensor-inventory"
10
11SRC_URI += "file://config.yaml"
12
13S = "${WORKDIR}"
14
15do_install() {
16 # This recipe is supposed to create an output yaml file with
17 # sensor data extracted from the mrw.
18 # provides a sample output file.
19
Ratan Gupta65e6e472017-03-17 19:37:28 +053020 DEST=${D}${sensor_datadir}
Ratan Gupta3aa591f2017-03-06 17:05:11 +053021 install -d ${DEST}
22 install config.yaml ${DEST}/sensor.yaml
23}