blob: e28bc37c0019e44e159db13962aff95f3100af4e [file] [log] [blame]
George Hung58253a82020-06-11 21:20:11 +08001DESCRIPTION = "Report CPLD Version"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit systemd
7
8SRC_URI = " file://cpld_version.sh \
9 file://cpld-version.service \
10 "
11
12S = "${WORKDIR}"
13
14DEPENDS = "systemd"
Brandon Kim1e427092021-08-10 15:46:03 -070015RDEPENDS:${PN} = "bash"
George Hung58253a82020-06-11 21:20:11 +080016
Brandon Kim1e427092021-08-10 15:46:03 -070017SYSTEMD_SERVICE:${PN} = "cpld-version.service"
George Hung58253a82020-06-11 21:20:11 +080018
19do_install() {
20 install -d ${D}${bindir}
21 install -m 0755 ${S}/cpld_version.sh ${D}${bindir}/
22
23 install -d ${D}${systemd_system_unitdir}
24 install -m 0644 ${S}/cpld-version.service ${D}${systemd_system_unitdir}
25}