blob: 13c4e52bf38b2e2c118f64aa7c050a37afede80f [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "Help browser for the GNOME desktop"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
7inherit gnomebase autotools-brokensep gsettings gettext gtk-doc
8
9SRC_URI[archive.md5sum] = "776e29bd16424c8712cbf340cfe6429b"
10SRC_URI[archive.sha256sum] = "e3d6527c5963d73206891b32f1f23363164be57de248555513bd0be77a7bd045"
11
12DEPENDS += " \
13 libxml2-native \
14 glib-2.0-native \
15 itstool-native \
16 gtk+3 \
17 appstream-glib \
18 libxslt \
19 sqlite3 \
20 webkitgtk \
21 yelp-xsl \
22"
23
24do_configure_prepend() {
25 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
26}
27
28FILES_${PN} += " \
29 ${datadir}/metainfo \
30 ${datadir}/yelp-xsl \
31"
32
33RDEPENDS_${PN} += "yelp-xsl"