blob: 96c8bb26c998c0d0e35fc25dbab29a23fe509d30 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001DESCRIPTION = "Blueman is a GTK+ Bluetooth Manager"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5DEPENDS = "bluez5 python3-pygobject python3-cython-native python3-setuptools-native intltool-native"
6
7inherit autotools systemd gsettings python3native gtk-icon-cache
8
9SRC_URI = " \
10 https://github.com/blueman-project/blueman/releases/download/${PV}/blueman-${PV}.tar.xz \
11 file://0001-Search-for-cython3.patch \
Brad Bishop2d39a062019-10-28 08:33:36 -040012 file://0002-fix-fail-to-enable-bluetooth.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040013"
14SRC_URI[md5sum] = "9de89abb31be45bdbf11f7884764a2dc"
15SRC_URI[sha256sum] = "f1eab2334e5a1587defa80900901048d14c2e8ffa8c0cff7240bc9937a61dbc3"
16
17EXTRA_OECONF = " \
18 --disable-runtime-deps-check \
19 --disable-schemas-compile \
20"
21
22SYSTEMD_SERVICE_${PN} = "${BPN}-mechanism.service"
23SYSTEMD_AUTO_ENABLE_${PN} = "disable"
24
25RRECOMENDS_${PN} += "adwaita-icon-theme"
26RDEPENDS_${PN} += " \
27 python3-core \
28 python3-dbus \
29 packagegroup-tools-bluetooth \
30"
31
32PACKAGECONFIG ??= "thunar"
33PACKAGECONFIG[thunar] = "--enable-thunar-sendto,--disable-thunar-sendto"
34
35FILES_${PN} += " \
36 ${datadir}/dbus-1 \
37 ${datadir}/Thunar \
38 ${systemd_user_unitdir} \
39 ${exec_prefix}${systemd_system_unitdir} \
40 ${PYTHON_SITEPACKAGES_DIR} \
41"
42
43FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_blueman.a"
44
45# In code, path to python is a variable that is replaced with path to native version of it
46# during the configure stage, e.g ../recipe-sysroot-native/usr/bin/python3-native/python3.
47# Replace it with #!/usr/bin/env python3
48do_install_append() {
49 sed -i "1s/.*/#!\/usr\/bin\/env python3/" ${D}${prefix}/libexec/blueman-rfcomm-watcher \
50 ${D}${prefix}/libexec/blueman-mechanism \
51 ${D}${bindir}/blueman-tray \
52 ${D}${bindir}/blueman-services \
53 ${D}${bindir}/blueman-sendto \
54 ${D}${bindir}/blueman-report \
55 ${D}${bindir}/blueman-manager \
56 ${D}${bindir}/blueman-assistant \
57 ${D}${bindir}/blueman-applet \
58 ${D}${bindir}/blueman-adapters
59}