blob: 286b0f60661cc9c677bd2b3cd5df7ff80cff5ca7 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Distributed block device driver for Linux"
2DESCRIPTION = "DRBD mirrors a block device over the network to another machine.\
3DRBD mirrors a block device over the network to another machine.\
4Think of it as networked raid 1. It is a building block for\
5setting up high availability (HA) clusters."
6HOMEPAGE = "http://www.drbd.org/"
7SECTION = "admin"
8LICENSE = "GPLv2+"
9LIC_FILES_CHKSUM = "file://COPYING;md5=5574c6965ae5f583e55880e397fbb018"
10
11SRC_URI = "git://github.com/LINBIT/drbd-utils;name=drbd-utils \
12 git://github.com/LINBIT/drbd-headers;name=drbd-headers;destsuffix=git/drbd-headers \
Brad Bishopc1d34332019-09-09 14:56:00 -040013 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-drbd-utils-support-usrmerge.patch','',d)} \
Brad Bishopc342db32019-05-15 21:57:59 -040014 "
Brad Bishop2d39a062019-10-28 08:33:36 -040015# v9.11.0
16SRCREV_drbd-utils = "63092751e76e1fba397e53df4be5c1161b83a223"
17SRCREV_drbd-headers = "d100ee01bf5aa8d5220767e4e35c4224faa8d865"
Brad Bishopc342db32019-05-15 21:57:59 -040018
19S = "${WORKDIR}/git"
20
21UPSTREAM_CHECK_URI = "https://github.com/LINBIT/drbd-utils/releases"
22
23SYSTEMD_SERVICE_${PN} = "drbd.service"
24SYSTEMD_AUTO_ENABLE = "disable"
25
26inherit autotools-brokensep systemd
27
28EXTRA_OECONF = " \
29 --with-initdir=/etc/init.d \
30 --without-pacemaker \
31 --without-rgmanager \
32 --without-bashcompletion \
33 --with-distro debian \
34 --with-initscripttype=both \
35 --with-systemdunitdir=${systemd_unitdir}/system \
36 --without-manual \
37 "
38
Brad Bishop26bdd442019-08-16 17:08:17 -040039# If we have inherited reproducible_build, we want to use it.
40export WANT_DRBD_REPRODUCIBLE_BUILD = "yes"
41
Brad Bishopc342db32019-05-15 21:57:59 -040042do_install_append() {
43 # don't install empty /var/lock and /var/run to avoid conflict with base-files
44 rm -rf ${D}${localstatedir}/lock
45 rm -rf ${D}${localstatedir}/run
46}
47
48RDEPENDS_${PN} += "bash perl-module-getopt-long perl-module-exporter perl-module-constant perl-module-overloading perl-module-exporter-heavy"
49
50# The drbd items are explicitly put under /lib when installed.
51#
52FILES_${PN} += "/run"
53FILES_${PN} += "${nonarch_base_libdir}/drbd \
54 ${nonarch_libdir}/drbd \
55 ${nonarch_libdir}/tmpfiles.d"
56FILES_${PN}-dbg += "${nonarch_base_libdir}/drbd/.debug"