blob: e3853a201c0a6c26288008424153cab267ce1748 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "A multi-platform library for OpenGL, OpenGL ES, Vulkan, window and input"
2HOMEPAGE = "https://www.glfw.org/"
3DESCRIPTION = "GLFW is an Open Source, multi-platform library for OpenGL, \
4OpenGL ES and Vulkan application development. It provides a simple, \
5platform-independent API for creating windows, contexts and surfaces, reading \
6input, handling events, etc."
7LICENSE = "Zlib"
8LIC_FILES_CHKSUM = "file://LICENSE.md;md5=98d93d1ddc537f9b9ea6def64e046b5f"
9SECTION = "lib"
10
11inherit pkgconfig cmake
12
13S = "${WORKDIR}/git"
14SRC_URI = "git://github.com/glfw/glfw.git"
15SRCREV = "d25248343e248337284dfbe5ecd1eddbd37ae66d"
16
17EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON"
18
19DEPENDS = "libpng libglu zlib libxrandr libxinerama libxi libxcursor"
20REQUIRED_DISTRO_FEATURES = "x11"
21
22COMPATIBLE_HOST_libc-musl = "null"