blob: f5066da0d8761249414585faf1637c6f35514bf9 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Persistent Memory Development Kit"
2DESCRIPTION = "Persistent Memory Development Kit"
3HOMEPAGE = "http://pmem.io"
4SECTION = "libs"
Brad Bishop2d39a062019-10-28 08:33:36 -04005LICENSE = "BSD-3-Clause"
Brad Bishop26bdd442019-08-16 17:08:17 -04006LIC_FILES_CHKSUM = "file://LICENSE;md5=7db1106255a1baa80391fd2e21eebab7"
7DEPENDS = "ndctl"
8
9# Required to have the fts.h header for musl
10DEPENDS_append_libc-musl = " fts"
11
12S = "${WORKDIR}/git"
13
14SRC_URI = "git://github.com/pmem/pmdk.git \
15 file://0001-jemalloc-jemalloc.cfg-Specify-the-host-when-building.patch \
16 file://0002-Makefile-Don-t-install-the-docs.patch \
Brad Bishop63ae8782019-10-09 09:56:13 -040017 file://0001-os_posix-Use-__FreeBSD__-to-control-secure_getenv-de.patch \
Brad Bishop26bdd442019-08-16 17:08:17 -040018 "
19
Brad Bishop63ae8782019-10-09 09:56:13 -040020SRCREV = "bc5e309485df61c452d08367e4b13ba9dfed5071"
Brad Bishop26bdd442019-08-16 17:08:17 -040021
22inherit autotools-brokensep pkgconfig
23
24# Fix jemalloc error:
25# | configure: error: cannot run C compiled programs.
26# | If you meant to cross compile, use `--host'.
27#
28# Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp]
Brad Bishop63ae8782019-10-09 09:56:13 -040029EXTRA_OEMAKE = "BUILD_EXAMPLES='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
Brad Bishop26bdd442019-08-16 17:08:17 -040030
31# Fix the missing fts libs when using musl
32EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"
33
34do_install() {
35 oe_runmake prefix=${prefix} DESTDIR=${D} install
36
37 # Remove uneeded files
38 rm -rf ${D}/usr/${baselib}/pmdk_debug
39}
40
41# Include these by default otherwise the SDK is not very useful
42FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio"
43FILES_${PN} += "${libdir}/*so*"
44FILES_${PN} += "${libdir}/pkgconfig/*.pc"
45FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/"
46FILES_${PN} += "/usr/etc"
47FILES_${PN} += "/usr/share"
48
49COMPATIBLE_HOST='(x86_64).*'