blob: 2b7571e232deec1eeaaf28fde97195c5746036c1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Linux SCSi tools to service maintain disk storage devices"
2DESCRIPTION = "scsirastools were designed to add to the Serviceability of \
3 SCSI devices under Linux so that the system does not have \
4 to be rebooted or taken out of service to perform common \
5 maintenance or service functions. It handles SCSI, \
6 Linux SW RAID, SAS, SATA, and USB devices via SCSI emulation."
7HOMEPAGE = "http://scsirastools.sourceforge.net/"
Brad Bishop2d39a062019-10-28 08:33:36 -04008LICENSE = "BSD-3-Clause"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=687ea108478d26152ae46eb29d9d1545"
10
11DEPENDS += "groff-native"
12
13SRC_URI = "http://prdownloads.sourceforge.net/scsirastools/scsirastools-${PV}.tar.gz \
14 file://mdadm.patch;apply=no \
15 file://print-format.patch \
16"
17SRC_URI[md5sum] = "6271a61b2ce40aaf33ef61775148cda1"
18SRC_URI[sha256sum] = "e7b997e75decb06a650c42c35cd63d0c94c34e39cf133c723337b0eeabbfdf6a"
19
20inherit autotools update-rc.d
21
22# mdadm Makefile has CC set to gcc, hence override CC to ${CC}
23EXTRA_OEMAKE += "CC='${CC}'"
24
25
26do_configure_append() {
27 oe_runmake -C mdadm.d mdadm-1.3.0
28 patch -p0 < ${WORKDIR}/mdadm.patch
29}
30INITSCRIPT_PACKAGES = "${PN}-diskmon ${PN}-raidmon"
31INITSCRIPT_NAME_${PN}-diskmon = "sgdisk"
32INITSCRIPT_PARAMS_${PN}-diskmon = "defaults 80 20"
33INITSCRIPT_NAME_${PN}-raidmon = "sgraid"
34INITSCRIPT_PARAMS_${PN}-raidmon = "defaults 80 20"
35
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080036PACKAGES =+ "${PN}-diskmon"
37PACKAGES =+ "${PN}-raidmon"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050038
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080039RPROVIDES_${PN}-dbg += "${PN}-diskmon-dbg ${PN}-raidmon-dbg"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050040
41FILES_${PN}-diskmon = "${sbindir}/sgdiskmon ${sysconfdir}/init.d/sgdisk"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050042
43FILES_${PN}-raidmon = "${sbindir}/sgraidmon ${sysconfdir}/init.d/sgraid"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050044
45RDEPENDS_${PN} += "bash"
Brad Bishop90ca7472019-08-20 09:15:15 -040046RDEPENDS_${PN}-diskmon += "${PN} bash"
47RDEPENDS_${PN}-raidmon += "${PN} bash"