blob: 9032a7c1edfcb65bbd5d514c5ba330f5d4d8ce6d [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "The ssl.match_hostname() function from Python 3.4"
2DESCRIPTION = "The Secure Sockets layer is only actually secure if you check the hostname in the \
3certificate returned by the server to which you are connecting, and verify that it matches to hostname \
4that you are trying to reach. But the matching logic, defined in RFC2818, can be a bit tricky to implement \
5on your own. So the ssl package in the Standard Library of Python 3.2 and greater now includes a \
6match_hostname() function for performing this check instead of requiring every application to \
7implement the check separately. This backport brings match_hostname() to users of earlier versions of Python"
8
9LICENSE = "GPLv2"
Brad Bishop2d39a062019-10-28 08:33:36 -040010LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b2adbe8bfdeb625c9a01afd9aaa66619"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
Brad Bishop2d39a062019-10-28 08:33:36 -040012SRC_URI[md5sum] = "32d2f593af01a046bec3d2f5181a420a"
13SRC_URI[sha256sum] = "bb82e60f9fbf4c080eabd957c39f0641f0fc247d9a16e31e26d594d8f42b9fd2"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014
15PYPI_PACKAGE = "backports.ssl_match_hostname"
16inherit pypi setuptools
Patrick Williamsddad1a12017-02-23 20:36:32 -060017
18RDEPENDS_${PN} += "${PYTHON_PN}-pkgutil"