blob: cfe93f0253d643536cb62b2e6aaa472ca151a8d6 [file] [log] [blame]
Andrew Geissler2daf84b2023-03-31 09:57:23 -05001SUMARRY = "NIST Certified SCAP 1.2 toolkit"
2
3DEPENDS:append = " xmlsec1"
4
5require openscap.inc
6
7inherit systemd
8
9SRCREV = "55efbfda0f617e05862ab6ed4862e10dbee52b03"
10SRC_URI = "git://github.com/OpenSCAP/openscap.git;branch=maint-1.3;protocol=https"
11
12SYSTEMD_PACKAGES = "${PN}"
13SYSTEMD_SERVICE:${PN} = "oscap-remediate.service"
14
15do_install:append () {
16 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
17 install -D -m 0644 ${B}/oscap-remediate.service ${D}${systemd_system_unitdir}/oscap-remediate.service
18 fi
19}