blob: a533724312ae7a873641361feff36a6ec4cfa141 [file] [log] [blame]
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}/${MACHINE}:"
Brad Bishopc7d1cd92020-09-09 09:57:07 -04002OBMC_CONSOLE_HOST_TTY = "ttyS0"
3
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03004SRC_URI:remove = "file://${BPN}.conf"
Brad Bishopc7d1cd92020-09-09 09:57:07 -04005SRC_URI += "file://server.ttyS0.conf"
6
Konstantin Aladyshev2de8c602021-09-01 11:34:44 +03007do_install:append() {
Brad Bishopc7d1cd92020-09-09 09:57:07 -04008 # Remove upstream-provided configuration
9 rm -rf ${D}${sysconfdir}/${BPN}
10
11 # Install the server configuration
12 install -m 0755 -d ${D}${sysconfdir}/${BPN}
13 install -m 0644 ${WORKDIR}/*.conf ${D}${sysconfdir}/${BPN}/
14
15}