blob: be3dc8e64a6b61938abf8dd784a1ae611c6438fe [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
Andrew Geissler2ee498a2020-05-29 15:52:06 -05005LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geissler2ee498a2020-05-29 15:52:06 -05007SRC_URI[md5sum] = "80d288c186dd02579e1561494b45aa41"
8SRC_URI[sha256sum] = "bd2deffc983827510e5145fb66e4cc0f577480c62fe0b4882139f8f7d27ae9a3"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10inherit pypi ptest setuptools3
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
Andrew Geissler2ee498a2020-05-29 15:52:06 -050016DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
17
Andrew Geissler82c905d2020-04-13 13:39:40 -050018RDEPENDS_${PN} += "\
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-numbers \
21"
22
23RDEPENDS_${PN}-ptest += " \
24 ${PYTHON_PN}-pytz \
25"
26
27do_install_ptest() {
28 install -d ${D}${PTEST_PATH}/tests
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
32BBCLASSEXTEND = "native nativesdk"