blob: f870104015ce461f49a21517397c90e52c6dcc6c [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "Parallelism library for C++ - runtime files \
2 TBB is a library that helps you leverage multi-core processor \
3 performance without having to be a threading expert. It represents a \
4 higher-level, task-based parallelism that abstracts platform details \
5 and threading mechanism for performance and scalability."
6HOMEPAGE = "http://threadingbuildingblocks.org/"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009PRDATE = "20170412"
10BRANCH = "tbb_2017"
11SRCREV = "a2cfdfe946933cbe38bffe1d8086ae36f06691a3"
12PV = "${PRDATE}+${SRCPV}"
13SRC_URI = "git://github.com/01org/tbb;branch=${BRANCH} \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014 file://cross-compile.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015 file://0001-mallinfo-is-glibc-specific-API-mark-it-so.patch \
Brad Bishop2eeb5252018-09-10 18:40:16 +000016 file://0002-linux-Fix-gcc-version-check.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://tbb.pc \
18"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
Brad Bishopd7bf8c12018-02-25 22:55:05 -050020S = "${WORKDIR}/git"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
22COMPILER ?= "gcc"
23COMPILER_toolchain-clang = "clang"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025do_compile() {
26 oe_runmake compiler=${COMPILER} arch=${HOST_ARCH} runtime=cc4
27}
28
29do_install() {
30 install -d ${D}${includedir} ${D}${libdir}/pkgconfig
31 rm ${S}/include/tbb/index.html -f
32 cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir}
33 install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir}
34 install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig
35}
36
37# fails with thumb enabled:
38# | arm-oe-linux-gnueabi-g++ -march=armv7-a -mthumb -mthumb-interwork -mfloat-abi=softfp -mfpu=neon -mtune=cortex-a9 -mcpu=cortex-a9 -D__ARM__ -D__LINUX_ARM_ARCH__=7 -funwind-tables -mvectorize-with-neon-quad -rdynamic --sysroot=/OE/sysroots/m14tv -c -MMD -DTBB_USE_DEBUG -g -O0 -DUSE_PTHREAD -fPIC -D__TBB_BUILD=1 -Wall -Wno-parentheses -Wno-non-virtual-dtor -O2 -pipe -g -feliminate-unused-debug-types -fpermissive -fvisibility-inlines-hidden -I../../src -I../../src/rml/include -I../../include ../../src/tbb/concurrent_queue.cpp
39# | {standard input}: Assembler messages:
40# | {standard input}:250: Error: thumb conditional instruction should be in IT block -- `strexeq r2,r3,[r4]'
41# ...
42# | make[1]: *** [concurrent_queue.o] Error 1
43ARM_INSTRUCTION_SET = "arm"
44SECURITY_CFLAGS_append = " -fPIC"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050045