blob: 0e3ea9e271e68eac1ed8823bd2877ae599fbc9e1 [file] [log] [blame]
Patrick Venture998ff012018-03-09 15:37:45 -08001SUMMARY = "Phosphor PID Fan Control"
2DESCRIPTION = "Fan Control"
Patrick Ventureffad0482018-09-29 09:19:22 -07003HOMEPAGE = "github.com/openbmc/phosphor-pid-control"
Patrick Venture998ff012018-03-09 15:37:45 -08004PR = "r1"
Patrick Ventureffad0482018-09-29 09:19:22 -07005PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
Patrick Venture998ff012018-03-09 15:37:45 -08008
9inherit autotools pkgconfig
10inherit pythonnative
11
12inherit phosphor-pid-control
13inherit obmc-phosphor-ipmiprovider-symlink
14
Patrick Ventureffad0482018-09-29 09:19:22 -070015S = "${WORKDIR}/git"
16SRC_URI = "git://github.com/openbmc/phosphor-pid-control"
Brad Bishop2f1bbb82018-11-28 20:40:39 -050017SRCREV = "208abce8d8553b7efc1d136fd599d6549d3715a0"
Patrick Ventureffad0482018-09-29 09:19:22 -070018
Patrick Venture998ff012018-03-09 15:37:45 -080019# Each platform will need a service file that starts
20# at an appropriate time per system. For instance, if
21# your system relies on passive dbus for fans or other
22# sensors then it may be prudent to wait for all of them.
23
24DEPENDS += "autoconf-archive-native"
25DEPENDS += "python-pyyaml-native"
26DEPENDS += "python-mako-native"
27DEPENDS += "sdbusplus"
28DEPENDS += "phosphor-logging"
29DEPENDS += "libevdev"
30DEPENDS += "libconfig"
31
32# We depend on someone providing their system's configuration.
33DEPENDS += "virtual/phosphor-fans-sensor-inventory"
34# We depend on this to be built first so we can build our providers.
35DEPENDS += "phosphor-ipmi-host"
36
37RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
38
39FILES_${PN} = "${sbindir}/swampd ${sbindir}/setsensor"
40
Patrick Venture26f8c6c2018-07-27 07:27:01 -070041# The following installs the OEM IPMI handler for the fan controls.
42FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
43FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
44FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
45FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
Patrick Venture998ff012018-03-09 15:37:45 -080046
47EXTRA_OECONF = "SENSOR_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/sensor-list.yaml \
48 PID_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/pid-list.yaml \
49 ZONE_YAML_GEN=${STAGING_DIR_NATIVE}${sensor_datadir}/zone-info.yaml"
50
Patrick Venture26f8c6c2018-07-27 07:27:01 -070051HOSTIPMI_PROVIDER_LIBRARY += "libmanualcmds.so"