Andrew Geissler | 4b7c115 | 2020-11-30 19:55:29 -0600 | [diff] [blame] | 1 | SUMMARY = "Heap memory profiler for Linux" |
| 2 | DESCRIPTION = "Heaptrack traces all memory allocations and annotates these \ |
| 3 | events with stack traces. Dedicated analysis tools then allow you to interpret \ |
| 4 | the heap memory profile to find hotspots to reduce memory, leaks, allocation \ |
| 5 | hotspots and temporary allocations" |
| 6 | HOMEPAGE = "https://phabricator.kde.org/source/heaptrack/" |
| 7 | LICENSE = "LGPL-2.1" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c" |
| 9 | |
| 10 | DEPENDS = "zlib boost libunwind elfutils" |
| 11 | |
| 12 | SRC_URI = "git://github.com/KDE/heaptrack.git;protocol=https \ |
| 13 | file://0001-libheaptrack-Replace-__pid_t-with-pid_t.patch \ |
| 14 | file://0002-heaptrack_inject-Include-dlfcn.h-for-dlopen-dlclose.patch \ |
| 15 | file://0003-heaptrack_preload-Make-noexcept-attribute-conditiona.patch \ |
| 16 | file://0004-backtrace-Always-include-stdint.h.patch \ |
| 17 | " |
| 18 | |
| 19 | SRCREV = "bc9e3744bcc47de978673d1e382f4125a1ab5fa8" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit cmake |
| 24 | |
| 25 | EXTRA_OECMAKE += "-DHEAPTRACK_BUILD_GUI=OFF" |
| 26 | |
| 27 | # libunwind is not yet ported to RISCV |
| 28 | COMPATIBLE_HOST_riscv32 = "null" |
| 29 | COMPATIBLE_HOST_riscv64 = "null" |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |