blob: c27afdb551eff0591f20d985f963e87cd1d4ff7d [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6DEPENDS = "c-ares cunit jansson libev libevent libxml2 openssl zlib"
7
8UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
9
10SRC_URI = "\
11 https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
12 file://0001-fetch-ocsp-response-use-python3.patch \
13"
14SRC_URI[md5sum] = "de52cd6b587b76486346745514972995"
15SRC_URI[sha256sum] = "a2d216450abd2beaf4e200c168957968e89d602ca4119338b9d7ab059fd4ce8b"
16
17inherit cmake manpages pythonnative
18PACKAGECONFIG[manpages] = ""
19
20# examples are never installed, and don't need to be built in the
21# first place
22EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=ON"
23
24do_install_append() {
25 rm ${D}${bindir}/deflatehd ${D}${bindir}/inflatehd
26}
27
28PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
29
30RDEPENDS_${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
31RDEPENDS_${PN}_class-native = ""
32RDEPENDS_${PN}-proxy = "openssl python3-core python3-io python3-shell"
33
34ALLOW_EMPTY_${PN} = "1"
35FILES_${PN} = ""
36FILES_lib${PN} = "${libdir}/*${SOLIBS}"
37FILES_${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
38FILES_${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
39FILES_${PN}-server = "${bindir}/nghttpd"
40
41BBCLASSEXTEND = "native"