blob: 25e0af3ff6060aa7ca20fd5d53b6b2c47a024317 [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "A client-side C library implementing the SSH2 protocol"
2HOMEPAGE = "http://www.libssh2.org/"
3SECTION = "libs"
4
5DEPENDS = "zlib"
6
7LICENSE = "BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://COPYING;md5=c5cf34fc0acb44b082ef50ef5e4354ca"
9
10SRC_URI = "http://www.libssh2.org/download/${BP}.tar.gz"
11
12SRC_URI[md5sum] = "1beefafe8963982adc84b408b2959927"
13SRC_URI[sha256sum] = "d5fb8bd563305fd1074dda90bd053fb2d29fc4bce048d182f96eaa466dfadafd"
14
15inherit autotools pkgconfig
16
17EXTRA_OECONF += "\
18 --with-libz \
19 --with-libz-prefix=${STAGING_LIBDIR} \
20 "
21
22# only one of openssl and gcrypt could be set
23PACKAGECONFIG ??= "openssl"
24PACKAGECONFIG[openssl] = "--with-crypto=openssl --with-libssl-prefix=${STAGING_LIBDIR}, , openssl"
25PACKAGECONFIG[gcrypt] = "--with-crypto=libgcrypt --with-libgcrypt-prefix=${STAGING_EXECPREFIXDIR}, , libgcrypt"
26
27BBCLASSEXTEND = "native"