blob: 6ca18b8b330d00db434081f7f655f0e4a733b17c [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Xfce4 development tools"
2HOMEPAGE = "http://www.xfce.org"
3SECTION = "x11/libs"
4LICENSE = "GPL-2.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "glib-2.0"
8DEPENDS:append:class-target = " ${BPN}-native"
9
10SRC_URI = "http://archive.xfce.org/src/xfce/${BPN}/${@'${PV}'[0:4]}/${BPN}-${PV}.tar.bz2 \
11 file://0001-m4macros-Check-for-a-function-provided-by-libX11-in-.patch \
12 "
13SRC_URI:append:class-target = " file://0001-Run-native-xdt-csource-on-tests.patch"
14SRC_URI[sha256sum] = "eedb4fc955f0e3459c46864ff98579295db2b900743e0ff69cad5970ba76be37"
15
16inherit autotools pkgconfig
17
18do_install:append() {
19 install -d ${D}${datadir}/aclocal
20 install -m 644 ${S}/m4macros/*.m4 ${D}${datadir}/aclocal/
21}
22
23FILES:${PN} += "${datadir}/xfce4/dev-tools/m4macros/*.m4"
24
25RDEPENDS:${PN} = "bash"
26
27BBCLASSEXTEND = "native"