blob: d88b9a2f144226d4c95e467141bd309f0c572b55 [file] [log] [blame]
SpencerKu67f272f2020-03-24 16:18:14 +08001SUMMARY = "Hotswap Controller Setting Changing"
2DESCRIPTION = "Hotswap Controller Setting Changing Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit systemd
8
9DEPENDS += "systemd"
Willy Tua38b7cc2021-08-10 15:33:55 -070010RDEPENDS:${PN} += "bash"
SpencerKu67f272f2020-03-24 16:18:14 +080011
Willy Tua38b7cc2021-08-10 15:33:55 -070012FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
13SRC_URI:append = " file://gsj-hotswap-change-setting.sh \
SpencerKu67f272f2020-03-24 16:18:14 +080014 file://gsj-hotswap-change-setting.service \
15 "
16
17do_install() {
18 install -d ${D}${bindir}
19 install -m 0755 ${WORKDIR}/gsj-hotswap-change-setting.sh ${D}${bindir}/
20
21 install -d ${D}${systemd_unitdir}/system/
22 install -m 0644 ${WORKDIR}/gsj-hotswap-change-setting.service ${D}${systemd_unitdir}/system
23}
24
25SYSTEMD_PACKAGES = "${PN}"
Willy Tua38b7cc2021-08-10 15:33:55 -070026SYSTEMD_SERVICE:${PN} = "gsj-hotswap-change-setting.service"