blob: cc28ec77cdb38cf825264824c435a47225456384 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "An alternative to dbug-glib."
2DESCRIPTION = "An alternative to dbus-glib. It is designed specifically to \
3make it comfortable to work with very large and potentially \
4complex D-Bus services like e.g. DeviceKit-disks"
5
6HOMEPAGE = "http://cgit.freedesktop.org/~david/eggdbus"
7LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
9 file://src/eggdbus/eggdbus.h;md5=6b312aef57ed8d738b3f131ad037d6c2"
10
11DEPENDS = "dbus glib-2.0 dbus-glib eggdbus-native"
12DEPENDS_class-native = "dbus-native glib-2.0-native dbus-glib-native"
13
14SRC_URI = "http://cgit.freedesktop.org/~david/${BPN}/snapshot/${BPN}-${PV}.tar.bz2 \
15 file://gtk-doc.patch \
16"
17SRC_URI_append_class-target = "file://marshal.patch"
18SRC_URI[md5sum] = "0a111faa54dfba2cf432c2c8e8a76e06"
19SRC_URI[sha256sum] = "3ad26e271c1a879bafcd181e065fe0ed53b542299a773c3188c9edb25b895ed1"
20
21inherit autotools gtk-doc
22
23EXTRA_OECONF = " --disable-man-pages "
24
25BBCLASSEXTEND = "native"
26
27PARALLEL_MAKE = ""
28
29do_configure_prepend() {
30 # Create ChangeLog to walk around automake error.
31 # " Makefile.am: error: required file './ChangeLog' not found "
32 touch ${S}/ChangeLog
33}