blob: d4bad38b7a43921dafd05929fdc58570b174c989 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# Copyright (C) 2017 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "A quick-n-dirty BSD licensed clone of the GNU libc backtrace facility."
5HOMEPAGE = "http://www.freshports.org/devel/libexecinfo"
6LIC_FILES_CHKSUM = "file://execinfo.c;endline=25;md5=85bd3fa4ea9acae5182e29db063fe2e5"
7LICENSE = "BSD-2-Clause"
8SECTION = "libs"
9DEPENDS = ""
10
11SRC_URI = "http://distcache.freebsd.org/local-distfiles/itetcu/${BP}.tar.bz2 \
12 file://0001-makefile-Fix-build-on-linux.patch \
13 file://0002-execinfo-Fix-compiler-errors-found-with-newer-gcc-cl.patch \
14 "
15SRC_URI[md5sum] = "8e9e81c554c1c5d735bc877448e92b91"
16SRC_URI[sha256sum] = "c9a21913e7fdac8ef6b33250b167aa1fc0a7b8a175145e26913a4c19d8a59b1f"
17
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018CFLAGS += "-fno-omit-frame-pointer -D_GNU_SOURCE"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019
20do_install() {
21 install -D -m 0744 ${S}/execinfo.h ${D}${includedir}/execinfo.h
22 install -D -m 0744 ${S}/stacktraverse.h ${D}${includedir}/stacktraverse.h
23 install -D -m 0744 ${B}/libexecinfo.a ${D}${libdir}/libexecinfo.a
24 install -D -m 0755 ${B}/libexecinfo.so.1 ${D}${libdir}/libexecinfo.so.1
25 ln -s libexecinfo.so.1 ${D}${libdir}/libexecinfo.so
26}
27#
28# We will skip parsing for non-musl systems
29#
30COMPATIBLE_HOST = ".*-musl.*"
31