blob: 489f8ad9e2168799e10890c42d49f08dd346aa2e [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "A portable audio library"
2SECTION = "libs/multimedia"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=26107732c2ab637c5710446fcfaf02df"
5
6PV = "v190600"
7
8SRC_URI = "http://www.portaudio.com/archives/pa_stable_v190600_20161030.tgz \
9 file://ldflags.patch"
10SRC_URI[md5sum] = "4df8224e047529ca9ad42f0521bf81a8"
11SRC_URI[sha256sum] = "f5a21d7dcd6ee84397446fa1fa1a0675bb2e8a4a6dceb4305a8404698d8d1513"
12
13S = "${WORKDIR}/portaudio"
14
15inherit autotools pkgconfig
16
17PACKAGECONFIG ??= "alsa jack"
18PACKAGECONFIG[alsa] = "--with-alsa, --without-alsa, alsa-lib,"
19PACKAGECONFIG[jack] = "--with-jack, --without-jack, jack,"
20
21EXTRA_OECONF = "--without-oss --without-asihpi"
22
23do_install_append() {
24 mkdir --parents ${D}${bindir}
25 for b in ${B}/bin/pa*; do
26 # Bit nasty, should always work
27 ${B}/*-libtool --mode install install $b ${D}${bindir}
28 done
29}
30
31PACKAGES += "portaudio-examples"
32FILES_portaudio-examples = "${bindir}"