blob: c72e536deb56c6c9a2fc6f147f068ee4c53752e1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A Perl DBI driver for SQLite"
2DESCRIPTION = "DBD::SQLite is a Perl DBI driver for SQLite, that includes the entire \
3thing in the distribution. So in order to get a fast transaction capable \
4RDBMS working for your perl project you simply have to install this \
5module, and nothing else. \
6"
7HOMEPAGE = "http://search.cpan.org/~ishigaki/DBD-SQLite/"
8
9SECTION = "libs"
10LICENSE = "Artistic-1.0 | GPL-1.0+"
11DEPENDS += "libdbi-perl-native"
12RDEPENDS_${PN} += "libdbi-perl \
13 sqlite3 \
14 perl-module-constant \
15 perl-module-locale \
16 perl-module-tie-hash \
17"
18
19LIC_FILES_CHKSUM = "file://LICENSE;md5=1726e2117494ba3e13e1c3d93f795360"
20
21SRC_URI = "http://search.cpan.org/CPAN/authors/id/I/IS/ISHIGAKI/DBD-SQLite-${PV}.tar.gz \
22 file://sqlite-perl-test.pl \
23"
24
25SRC_URI[md5sum] = "8f835ddacb9a4a92a52bbe2d24d18a8e"
26SRC_URI[sha256sum] = "3929a6dbd8d71630f0cb57f85dcef9588cd7ac4c9fa12db79df77b9d3a4d7269"
27
Brad Bishop316dfdd2018-06-25 12:45:53 -040028UPSTREAM_CHECK_REGEX = "DBD\-SQLite\-(?P<pver>(\d+\.\d+))(?!_\d+).tar"
29
Brad Bishopd7bf8c12018-02-25 22:55:05 -050030S = "${WORKDIR}/DBD-SQLite-${PV}"
31
32inherit cpan
33
34BBCLASSEXTEND = "native"
35
36do_install_append() {
37 if [ ${PERL_DBM_TEST} = "1" ]; then
38 install -m 755 -D ${WORKDIR}/sqlite-perl-test.pl ${D}/${bindir}/sqlite-perl-test.pl
39 fi
40}
41