blob: f2b1f1634d9650c5e6a8af02dde6359f9bd9f3fa [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001SUMMARY = "LDAP Perl module"
2DESCRIPTION = "Net::LDAP is a collection of modules that implements \
3a LDAP services API for Perl programs. The module may be used to \
4search directories or perform maintenance functions such as adding, \
5deleting or modifying entries."
6
7SECTION = "libs"
8
9LICENSE = "Artistic-1.0|GPLv1+"
10LIC_FILES_CHKSUM = "file://README;beginline=3;endline=5;md5=4d6588c2fa0d38ae162f6314d201d89e"
11
12SRC_URI = "http://search.cpan.org/CPAN/authors/id/M/MA/MARSCHAP/perl-ldap-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "d057c8db76913d95c0e460c7bdd98b27"
15SRC_URI[sha256sum] = "5f57dd261dc16ebf942a272ddafe69526598df71151a51916edc37a4f2f23834"
16
17S = "${WORKDIR}/perl-ldap-${PV}"
18
19inherit cpan
20
21do_configure_prepend() {
22 perl -pi -e 's/auto_install_now.*//g' Makefile.PL
23}
24
25RDEPENDS_${PN} = "perl \
26 libconvert-asn1-perl \
27 libio-socket-ssl-perl \
28 libauthen-sasl-perl \
29"