blob: 5b1c3f05b9592893a514ffffaa9d6a4d940ddf48 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "matplotlib is a python 2D plotting library which produces publication quality figures in a variety of hardcopy formats"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74"
5
6DEPENDS += "python-numpy freetype libpng python-dateutil python-pytz"
7RDEPENDS_${PN} = "python-core python-distutils python-numpy freetype libpng python-dateutil python-pytz"
8
9SRC_URI = "https://github.com/matplotlib/matplotlib/archive/v${PV}.tar.gz \
10 file://fix_setupext.patch \
11"
12SRC_URI[md5sum] = "89717c1ef3c6fdcd6fb1f3b597a4858c"
13SRC_URI[sha256sum] = "aebed23921562792b68b8ca355de5abc176af4424f1987e2fa95f65e5c5e7e89"
14S = "${WORKDIR}/matplotlib-${PV}"
15EXTRA_OECONF = "--disable-docs"
16
17inherit setuptools pkgconfig
18