blob: 9770af61102e021895e0a7fd0abdf7fd2e9214a5 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001# Add MicroBlaze Patches (only when using MicroBlaze)
2FILESEXTRAPATHS_append_microblaze := "${THISDIR}/gcc-7:"
3SRC_URI_append_microblaze = " \
4 file://0001-Revert.patch \
5 file://0002-microblaze.md-Improve-adddi3-and-subdi3-insn-definit.patch \
6 file://0003-PR-target-83013.patch \
7 file://0004-dejagnu-static-testing-on-qemu-suppress-warnings.patch \
8 file://0005-Testsuite-explicitly-add-fivopts-for-tests-that-depe.patch \
9 file://0006-Add-MicroBlaze-to-target-supports-for-atomic-builtin.patch \
10 file://0007-Update-MicroBlaze-strings-test-for-new-scan-assembly.patch \
11 file://0008-Allow-MicroBlaze-.weakext-pattern-in-testsuite.patch \
12 file://0009-Add-MicroBlaze-to-check_profiling_available-Testsuit.patch \
13 file://0010-Fix-atomic-side-effects.patch \
14 file://0011-Fix-atomic-boolean-return-value.patch \
15 file://0012-Fix-the-Microblaze-crash-with-msmall-divides-flag.patch \
16 file://0013-Add-MicroBlaze-ashrsi_3_with_size_opt.patch \
17 file://0014-Removed-MicroBlaze-moddi3-routinue.patch \
18 file://0015-MicroBlaze-fixed-missing-save-of-r18-in-fast_interru.patch \
19 file://0016-MicroBlaze-use-bralid-for-profiler-calls.patch \
20 file://0017-Disable-fivopts-by-default-Turn-off-ivopts-by-defaul.patch \
21 file://0018-Add-INIT_PRIORITY-support-Added-TARGET_ASM_CONSTRUCT.patch \
22 file://0019-MicroBlaze-add-optimized-lshrsi3-When-barrel-shifter.patch \
23 file://0020-Modified-MicroBlaze-trap-instruction.patch \
24 file://0021-Reducing-Stack-space-for-arguments-Currently-in-Micr.patch \
25 file://0022-Inline-Expansion-of-fsqrt-builtin.patch \
26 file://0023-Update-MicroBlaze-ashlsi3-movsf-patterns.patch \
27 file://0024-8-stage-pipeline-for-microblaze.patch \
28 file://0025-MicroBlaze-correct-the-const-high-double-immediate-v.patch \
29 file://0026-Fix-internal-compiler-error-with-msmall-divides.patch \
30 file://0027-Fix-the-calculation-of-high-word-in-a-long-long-64-b.patch \
31 file://0028-Add-new-bit-field-instructions.patch \
32 file://0029-Fix-bug-in-MB-version-calculation.patch \
33 file://0030-MicroBlaze-fixing-the-bug-in-the-bit-field-instructi.patch \
34 file://0031-Fixing-the-issue-with-MicroBlaze-builtin_alloc.patch \
35 file://0032-MicroBlaze-remove-bitfield-instructions-macros.patch \
36 file://0033-MicroBlaze-fix-signed-bit-fields-with-bit-field-inst.patch \
37 "
38