blob: 9d89895b0de9b2170615ad87c0a997d0410516ce [file] [log] [blame]
Patrick Williamsf7326942020-04-08 10:26:49 -05001SUMMARY = "sdbus++ dbus API / binding generator"
2DESCRIPTION = "Generates bindings against sdbusplus for dbus APIs"
3
Patrick Williams8564d352020-05-19 06:56:04 -05004inherit setuptools3
Patrick Williamsf7326942020-04-08 10:26:49 -05005
6include sdbusplus-rev.inc
7
Patrick Williams8564d352020-05-19 06:56:04 -05008## The sdbusplus repository has an Apache LICENSE file, which we would
9## normally check here, but the python setup script is in a subdirectory
10## which requires us to set ${S} below. When we change ${S} from the root
11## of the repository, bitbake can no longer find the LICENSE file. Point
12## to the common Apache license file in poky's meta instead.
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
15
16S="${WORKDIR}/git/tools"
17
Patrick Williamsf7326942020-04-08 10:26:49 -050018# Provide these aliases temporarily until everyone can move over to the
19# new package name.
20PROVIDES_class-native += "sdbusplus-native"
21PROVIDES_class-nativesdk += "sdbusplus-nativesdk"
22
23DEPENDS += " \
24 autoconf-archive-native \
25 ${PYTHON_PN}-inflection-native \
26 ${PYTHON_PN}-mako-native \
27 ${PYTHON_PN}-pyyaml-native \
28 "
29
30RDEPENDS_${PN} += " \
31 ${PYTHON_PN}-inflection \
32 ${PYTHON_PN}-mako \
33 ${PYTHON_PN}-pyyaml \
34 "
35
Patrick Williamsf7326942020-04-08 10:26:49 -050036BBCLASSEXTEND += "native nativesdk"