blob: 96c0e9ac49fcc59fdf4fa9246efc503cc45baa9a [file] [log] [blame]
Vijay Khemka4809bd12019-12-16 17:48:02 -08001SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5
6SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
Andrew Geisslerb76990c2020-05-31 13:31:43 +00007SRCREV = "9d91a39a3a760358a4c1a5e89fb5ef57d1bd7995"
Vijay Khemka4809bd12019-12-16 17:48:02 -08008
9S = "${WORKDIR}/git"
10
11PV = "1.0+git${SRCPV}"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16inherit cmake pkgconfig systemd
17
18SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.State.Boot.PostCode.service"
19
20DEPENDS += " \
21 sdbusplus \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
24 "