blob: efc18c39440cda7027f281c91936e2b3e588730e [file] [log] [blame]
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05301SUMMARY = "Phosphor User Manager Daemon"
2DESCRIPTION = "Daemon that does user management"
3HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05304LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +05306DEPENDS += "sdbusplus"
7DEPENDS += "phosphor-logging"
8DEPENDS += "phosphor-dbus-interfaces"
Tom Joseph926556d2018-07-10 12:23:06 -05009DEPENDS += "boost"
Andrew Geissler1de95de2018-10-09 04:10:28 +000010DEPENDS += "nss-pam-ldapd"
Brad Bishop44f3cce2019-03-22 23:41:42 -040011DEPENDS += "systemd"
Andrew Geissler314fcf32023-06-02 05:20:26 -050012SRCREV = "cf7aeddd82e300d9a0846ece3f23ac11b3d582c5"
Ed Tanous9936f862022-09-19 09:13:20 -070013PV = "1.0+git${SRCPV}"
14PR = "r1"
15
Patrick Williamsbccaff32023-04-14 11:24:47 -050016SRC_URI = "git://github.com/openbmc/phosphor-user-manager;branch=master;protocol=https"
Ninad Palsule34d21442023-03-09 10:20:38 -060017SRC_URI += "file://upgrade_hostconsole_group.sh"
Ed Tanous9936f862022-09-19 09:13:20 -070018
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig
22inherit obmc-phosphor-dbus-service
23inherit useradd
Vishwanatha Subbanna0ea6f632017-10-18 15:47:54 +053024
Nan Zhou175f5022022-08-29 17:43:49 +000025EXTRA_OEMESON = "-Dtests=disabled"
26
Ninad Palsule34d21442023-03-09 10:20:38 -060027do_install:append() {
28 install -d ${D}${libexecdir}
29 install -m 0755 ${WORKDIR}/upgrade_hostconsole_group.sh ${D}${libexecdir}/upgrade_hostconsole_group.sh
30}
31
Patrick Williams12fc9392021-08-06 09:16:53 -050032FILES:phosphor-ldap += " \
Patrick Ventured8014ce2019-04-04 10:03:09 -070033 ${bindir}/phosphor-ldap-conf \
Nagaraju Gorugantidf045f12018-09-03 21:56:42 -050034"
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020035FILES:${PN} += " \
Anton Blanchard397b2b12022-08-02 23:37:41 -060036 ${systemd_unitdir} \
Andrew Geissler30cd3822021-10-15 01:41:20 +000037 ${datadir}/dbus-1 \
Anton D. Kachalov31ecbfb2021-04-21 19:23:55 +020038 ${datadir}/phosphor-certificate-manager \
39"
Ed Tanous9936f862022-09-19 09:13:20 -070040
41USERADD_PACKAGES = "${PN} phosphor-ldap"
42
43PACKAGE_BEFORE_PN = "phosphor-ldap"
44DBUS_PACKAGES = "${USERADD_PACKAGES}"
45# add groups needed for privilege maintenance
46GROUPADD_PARAM:${PN} = "priv-admin; priv-operator; priv-user "
47GROUPADD_PARAM:phosphor-ldap = "priv-admin; priv-operator; priv-user "
48DBUS_SERVICE:${PN} += "xyz.openbmc_project.User.Manager.service"
Patrick Williams12fc9392021-08-06 09:16:53 -050049DBUS_SERVICE:phosphor-ldap = " \
Tom Joseph42276262018-10-07 05:51:04 -050050 xyz.openbmc_project.Ldap.Config.service \
Tom Joseph42276262018-10-07 05:51:04 -050051"
Ninad Palsule34d21442023-03-09 10:20:38 -060052
53EXTRA_USERS_PARAMS += " \
54 groupadd hostconsole; \
55 "
56
57EXTRA_USERS_PARAMS += " \
58 usermod --append --groups hostconsole root; \
59 "