blob: 9eac876ba16fad9eeaf2bd3ecddb7e92e68b1f04 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPLv2"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6DEPENDS = "pciutils libusb libusb-compat"
7
8SRC_URI = "https://download.flashrom.org/releases/flashrom-${PV}.tar.bz2 \
9 file://sst26.patch \
10 file://0001-platform-Add-riscv-to-known-platforms.patch \
11 "
12SRC_URI[md5sum] = "42d999990c735d88653627cefcc13b9a"
13SRC_URI[sha256sum] = "3702fa215ba5fb5af8e54c852d239899cfa1389194c1e51cb2a170c4dc9dee64"
14
15inherit pkgconfig
16
17do_install() {
18 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
19}