blob: 1b56685c571aeb2c669d132eafa414c9cf73f5b8 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "The Openobex project is an open source implementation of the \
2Object Exchange (OBEX) protocol."
3HOMEPAGE = "http://openobex.triq.net"
4SECTION = "libs"
5DEPENDS = "virtual/libusb0"
6DEPENDS_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}"
7
8LICENSE = "GPLv2 & LGPLv2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
10 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
11"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${PV}/${BP}-Source.tar.gz \
14"
15
16SRC_URI[md5sum] = "f6e0b6cb7dcfd731460a7e9a91429a3a"
17SRC_URI[sha256sum] = "158860aaea52f0fce0c8e4b64550daaae06df2689e05834697b7e8c7d73dd4fc"
18
19inherit cmake pkgconfig
20
21S = "${WORKDIR}/${BP}-Source"
22
23EXTRA_OECONF = " -DCMAKE_SKIP_RPATH=ON "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024EXTRA_OECMAKE += "-DBUILD_DOCUMENTATION=OFF"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26#--enable-apps --enable-syslog
27
Brad Bishop316dfdd2018-06-25 12:45:53 -040028ASNEEDED = ""
29
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030do_install_append () {
31 rmdir ${D}${bindir}
32}
33
34PACKAGES =+ "openobex-apps"
35FILES_${PN}-apps = "${bindir}/*"
36FILES_${PN} += "${libdir}/lib*.so.*"
37FILES_${PN}-dev += "${bindir}/openobex-config ${libdir}/cmake"
38DEBIAN_NOAUTONAME_${PN}-apps = "1"
39
40BBCLASSEXTEND = "native"