blob: 6e6413b4bcde8939118492c448e2068724d7df5a [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "SMS Gateway software"
2DESCRIPTION = "The SMS Server Tools 3 is a SMS Gateway software which can send and receive short messages through GSM modems and mobile phones."
3SECTION = "console/network"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4d21efa1bb2a186360dde4035f860682"
6HOMEPAGE = "http://smstools3.kekekasvi.com"
7
8SRC_URI = "http://smstools3.kekekasvi.com/packages/${BP}.tar.gz \
9 file://sms_binpath.patch \
10 file://scripts_no_bash.patch"
11
12SRC_URI[md5sum] = "6a9f038fb38a49cc3a4f8f14a88fb8af"
13SRC_URI[sha256sum] = "a26ba4c02b16f6cf13177bffca6c9230dc5fefaeba8e3030cd4e4905f6a92084"
14
15
16S = "${WORKDIR}/${BPN}"
17
18EXTRA_OEMAKE += "LFLAGS='${LDFLAGS}'"
19
20INITSCRIPT_NAME = "sms3"
21INITSCRIPT_PARAMS = "defaults"
22
23inherit update-rc.d
24
25do_install () {
26
27 install -d ${D}${bindir}
28 install -m 755 ${S}/src/smsd "${D}${bindir}/smsd"
29
30 install -m 755 ${S}/scripts/sendsms "${D}${bindir}/sendsms"
31 install -m 755 ${S}/scripts/sms2html "${D}${bindir}/sms2html"
32 install -m 755 ${S}/scripts/sms2unicode "${D}${bindir}/sms2unicode"
33 install -m 755 ${S}/scripts/unicode2sms "${D}${bindir}/unicode2sms"
34
35 install -d ${D}${sysconfdir}
36 install -m 644 ${S}/examples/smsd.conf.easy "${D}${sysconfdir}/smsd.conf"
37
38 install -d "${D}${localstatedir}/spool"
39 install -d "${D}${localstatedir}/spool/sms"
40 install -d "${D}${localstatedir}/spool/sms/incoming"
41 install -d "${D}${localstatedir}/spool/sms/outgoing"
42 install -d "${D}${localstatedir}/spool/sms/checked"
43
44 install -d ${D}${sysconfdir}/init.d
45 install -m 755 ${S}/scripts/sms3 "${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}"
46
47}