blob: 99f680f9ab79900b1d280d6bf30d3f8f8f8ebb23 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Fast data collector for Embedded Linux"
2HOMEPAGE = "http://fluentbit.io"
3BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
4
5SRC_URI = "http://fluentbit.io/releases/0.12/fluent-bit-${PV}.tar.gz \
6 file://jemalloc.patch \
7 file://0001-fluent-bit-shared-Link-with-lpthread.patch \
8 "
9SRC_URI[md5sum] = "6b4472cb7e7213a01425af9121576827"
10SRC_URI[sha256sum] = "8ec05365baea723033165687611b3bba3e67a77dce72e282e9f000f7acf9e37b"
11
12S = "${WORKDIR}/fluent-bit-${PV}"
13
14LICENSE = "Apache-2.0"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=2ee41112a44fe7014dce33e26468ba93"
16
17DEPENDS = "zlib"
18INSANE_SKIP_${PN}-dev += "dev-elf"
19
20inherit cmake systemd
21
22EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
23
Brad Bishop316dfdd2018-06-25 12:45:53 -040024# With Ninja it fails with:
25# ninja: error: build.ninja:134: bad $-escape (literal $ must be written as $$)
26OECMAKE_GENERATOR = "Unix Makefiles"
27
Brad Bishopd7bf8c12018-02-25 22:55:05 -050028SYSTEMD_SERVICE_${PN} = "td-agent-bit.service"
29
30TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"