blob: fba5156f6d0fb8d545df298880fa6ecb621d7232 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Terminal multiplexer"
2HOMEPAGE = "http://tmux.sourceforge.net"
3SECTION = "console/utils"
4
5LICENSE = "ISC"
6LIC_FILES_CHKSUM = "file://tmux.c;beginline=3;endline=17;md5=f256b76d52e7b4d02bf19144bdaca107"
7
8DEPENDS = "ncurses libevent"
9
10SRC_URI = "https://github.com/tmux/tmux/releases/download/${PV}/tmux-${PV}.tar.gz"
11SRC_URI[md5sum] = "d541ff392249f94c4f3635793556f827"
12SRC_URI[sha256sum] = "b17cd170a94d7b58c0698752e1f4f263ab6dc47425230df7e53a6435cc7cd7e8"
13
14inherit autotools pkgconfig
15
16PACKAGECONFIG ??= ""
17PACKAGECONFIG[utempter] = "ac_cv_header_utempter_h=yes,ac_cv_header_utempter_h=no,libutempter,"
18
19do_configure_prepend() {
20 # The 'compat' directory is needed for output during the build but it's
21 # not automatically created when building outside the source directory.
22 mkdir ${B}/compat
23}