blob: 42945288c451706c8b129d38be13abb4b169e9c8 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Libyui is a widget abstraction library providing Qt, GTK and ncurses frontends."
2LICENSE = "LGPLv3"
3LIC_FILES_CHKSUM = "file://COPYING.gpl-3;md5=d32239bcb673463ab874e80d47fae504 \
4 file://COPYING.lgpl-2.1;md5=4fbd65380cdd255951079008b364516c \
5 file://COPYING.lgpl-3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
6 "
7
8SRC_URI = "git://github.com/libyui/libyui.git \
9 file://0001-Fix-GCC-8-warning.patch \
10 file://0001-Fix-build-with-clang.patch \
11 "
12
13PV = "3.3.3+git"
14SRCREV = "2b634cb7821e2e79dd4b7a73caf8e67c50189376"
15
16S = "${WORKDIR}/git"
17
18inherit cmake gettext pkgconfig
19
20DEPENDS += "boost"
21
22BBCLASSEXTEND = "native nativesdk"
23
24do_configure_prepend () {
25 cd ${S}
26 ./bootstrap.sh
27 cd -
28}
29
30do_install_append () {
31 if [ "${libdir}" = "${base_prefix}/usr/lib" ] && [ -d ${D}/usr/lib64 ]; then
32 mv ${D}/usr/lib64 ${D}/usr/lib
33 fi
34}
35
36do_install_append_class-nativesdk () {
37 mkdir -p ${D}/${base_prefix}
38 mv ${D}/usr ${D}/${base_prefix}
39}
40
41FILES_${PN}-dev = "${libdir}/* ${includedir}/yui*"