blob: 63d9acf05d745f43ab5412e18a0f0953d51d92c3 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.bitbucket.org/"
9
10SECTION = "libs"
11LICENSE = "GD"
12LIC_FILES_CHKSUM = "file://COPYING;md5=07384b3aa2e0d39afca0d6c40286f545"
13
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
16SRC_URI = "git://github.com/libgd/libgd.git;branch=GD-2.2 \
17 "
18
19SRCREV = "8255231b68889597d04d451a72438ab92a405aba"
20
21S = "${WORKDIR}/git"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-webp \
30 --without-xpm \
31 --without-x \
32 "
33
34EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
35
36do_install_append() {
37 # cleanup buildpaths from gdlib.pc
38 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
39}
40
41PACKAGES += "${PN}-tools"
42
43FILES_${PN} = "${libdir}/lib*${SOLIBS}"
44FILES_${PN}-tools = "${bindir}/*"
45
46PROVIDES += "${PN}-tools"
47RPROVIDES_${PN}-tools = "${PN}-tools"
48RDEPENDS_${PN}-tools = "perl perl-module-strict"