blob: 28b652a640450fee688ca4ef477b0770dfb59dbd [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001DESCRIPTION = "The gflags package contains a C++ library that implements commandline flags processing. It includes built-in support for standard types such as string and the ability to define flags in the source file in which they are used"
2
3HOMEPAGE = "https://github.com/gflags/gflags"
4
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://COPYING.txt;md5=c80d1a3b623f72bb85a4c75b556551df"
7
8SRC_URI = "git://github.com/gflags/gflags.git"
9SRCREV = "f8a0efe03aa69b3336d8e228b37d4ccb17324b88"
10
11S = "${WORKDIR}/git"
12
13FILES_${PN}-dev += "${libdir}/cmake"
14
15inherit cmake
16
17EXTRA_OECMAKE="-DBUILD_SHARED_LIBS=ON -DREGISTER_INSTALL_PREFIX=OFF -DLIB_INSTALL_DIR=${baselib}"
18
19PACKAGES =+ "${PN}-bash-completion"
20FILES_${PN}-bash-completion += "${bindir}/gflags_completions.sh"
21RDEPENDS_${PN}-bash-completion = "bash bash-completion"
Brad Bishop316dfdd2018-06-25 12:45:53 -040022
23BBCLASSEXTEND = "native"