blob: 0903e90d7d13e0f9997b01f265e10e672c016cb6 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "Fast and portable XML parser and Jabber protocol library"
2HOMEPAGE = "https://github.com/meduketto/iksemel"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499"
6
7SRCREV = "978b733462e41efd5db72bc9974cb3b0d1d5f6fa"
8PV = "1.5+git${SRCPV}"
9
10SRC_URI = "git://github.com/meduketto/iksemel.git;protocol=https \
11 file://fix-configure-option-parsing.patch \
12 file://avoid-obsolete-gnutls-apis.patch"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig lib_package
17
18# TLS support requires either openssl or gnutls (if both are enabled openssl will be used).
19PACKAGECONFIG ?= "gnutls"
20
21PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
22PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
23
24EXTRA_OECONF = "--disable-python"