blob: 973fbe771edb89069e44759e98191add7f059ee2 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
4
5DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib polkit"
6
7SRC_URI = "http://upower.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "236bb439d9ff1151450b3d8582399532"
9SRC_URI[sha256sum] = "24bcc2f6ab25a2533bac70b587bcb019e591293076920f5b5e04bdedc140a401"
10
11inherit autotools pkgconfig gettext gobject-introspection systemd
12
13PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
14PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
15PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
16 --without-systemdutildir --without-systemdsystemunitdir,systemd"
17
18EXTRA_OECONF = " --with-backend=linux"
19
20SYSTEMD_SERVICE_${PN} = "upower.service"
21# don't start on boot by default - dbus does that on demand
22SYSTEMD_AUTO_ENABLE = "disable"
23
24do_configure_prepend() {
25 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
26 sed -i -e 's: doc : :g' ${S}/Makefile.am
27}
28
29RDEPENDS_${PN} += "dbus"
30RRECOMMENDS_${PN} += "pm-utils"
31FILES_${PN} += "${datadir}/dbus-1/ \
32 ${datadir}/polkit-1/ \
33 ${base_libdir}/udev/* \
34"