blob: 2748459855ea62938ed4286c9efe7565b0d97301 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi."
2HOMEPAGE = "https://github.com/sarfata/pi-blaster/"
3SECTION = "devel/libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3"
6
7SRC_URI = "git://github.com/sarfata/pi-blaster \
8 file://remove-initscript-lsb-dependency.patch \
9"
10
11S = "${WORKDIR}/git"
Patrick Williams8b8bc412016-08-17 15:02:23 -050012
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
15inherit update-rc.d autotools
16
17INITSCRIPT_PACKAGES = "${PN}"
18INITSCRIPT_NAME_${PN} = "${PN}.boot.sh"
19INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
20
21COMPATIBLE_MACHINE = "^rpi$"
22
23PACKAGE_ARCH = "${MACHINE_ARCH}"