blob: 4a7db1a4eabc556099b2f3290d493d28ab1786e2 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001python __anonymous() {
2 if "linux-raspberrypi-dev" not in d.getVar("PREFERRED_PROVIDER_virtual/kernel"):
3 msg = "Skipping linux-raspberrypi-dev as it is not the preferred " + \
4 "provider of virtual/kernel."
5 raise bb.parse.SkipRecipe(msg)
6}
7
8FILESEXTRAPATHS_prepend := "${THISDIR}/linux-raspberrypi:"
9
Brad Bishop316dfdd2018-06-25 12:45:53 -040010LINUX_VERSION ?= "4.16"
11LINUX_RPI_DEV_BRANCH ?= "rpi-4.16.y"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012
13SRCREV = "${AUTOREV}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014SRC_URI = " \
15 git://github.com/raspberrypi/linux.git;protocol=git;branch=${LINUX_RPI_DEV_BRANCH} \
16 file://0001-menuconfig-check-lxdiaglog.sh-Allow-specification-of.patch \
17 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018require linux-raspberrypi.inc
19
Brad Bishop6e60e8b2018-02-01 10:27:11 -050020# Disable version check so that we don't have to edit this recipe every time
21# upstream bumps the version
22KERNEL_VERSION_SANITY_SKIP = "1"