blob: 537659df12f6ee6dee475499b6374182dae4f89c [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001# This class is used to check recipes against public CVEs.
2#
3# In order to use this class just inherit the class in the
4# local.conf file and it will add the cve_check task for
5# every recipe. The task can be used per recipe, per image,
6# or using the special cases "world" and "universe". The
7# cve_check task will print a warning for every unpatched
8# CVE found and generate a file in the recipe WORKDIR/cve
9# directory. If an image is build it will generate a report
10# in DEPLOY_DIR_IMAGE for all the packages used.
11#
12# Example:
13# bitbake -c cve_check openssl
14# bitbake core-image-sato
15# bitbake -k -c cve_check universe
16#
17# DISCLAIMER
18#
19# This class/tool is meant to be used as support and not
20# the only method to check against CVEs. Running this tool
21# doesn't guarantee your packages are free of CVEs.
22
Brad Bishop37a0e4d2017-12-04 01:01:44 -050023# The product name that the CVE database uses. Defaults to BPN, but may need to
24# be overriden per recipe (for example tiff.bb sets CVE_PRODUCT=libtiff).
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025CVE_PRODUCT ??= "${BPN}"
Brad Bishop316dfdd2018-06-25 12:45:53 -040026CVE_VERSION ??= "${PV}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -050027
Patrick Williamsc0f7c042017-02-23 20:41:17 -060028CVE_CHECK_DB_DIR ?= "${DL_DIR}/CVE_CHECK"
29CVE_CHECK_DB_FILE ?= "${CVE_CHECK_DB_DIR}/nvd.db"
30
Brad Bishop316dfdd2018-06-25 12:45:53 -040031CVE_CHECK_LOG ?= "${T}/cve.log"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060032CVE_CHECK_TMP_FILE ?= "${TMPDIR}/cve_check"
33
34CVE_CHECK_DIR ??= "${DEPLOY_DIR}/cve"
35CVE_CHECK_MANIFEST ?= "${DEPLOY_DIR_IMAGE}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.cve"
36CVE_CHECK_COPY_FILES ??= "1"
37CVE_CHECK_CREATE_MANIFEST ??= "1"
38
39# Whitelist for packages (PN)
40CVE_CHECK_PN_WHITELIST = "\
41 glibc-locale \
42"
43
44# Whitelist for CVE and version of package
45CVE_CHECK_CVE_WHITELIST = "{\
Brad Bishop37a0e4d2017-12-04 01:01:44 -050046 'CVE-2014-2524': ('6.3','5.2',), \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060047}"
48
49python do_cve_check () {
50 """
51 Check recipe for patched and unpatched CVEs
52 """
53
Brad Bishop6e60e8b2018-02-01 10:27:11 -050054 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060055 patched_cves = get_patches_cves(d)
56 patched, unpatched = check_cves(d, patched_cves)
57 if patched or unpatched:
58 cve_data = get_cve_info(d, patched + unpatched)
59 cve_write_data(d, patched, unpatched, cve_data)
60 else:
61 bb.note("Failed to update CVE database, skipping CVE check")
62}
63
64addtask cve_check after do_unpack before do_build
Brad Bishop6e60e8b2018-02-01 10:27:11 -050065do_cve_check[depends] = "cve-check-tool-native:do_populate_sysroot cve-check-tool-native:do_populate_cve_db"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060066do_cve_check[nostamp] = "1"
67
68python cve_check_cleanup () {
69 """
70 Delete the file used to gather all the CVE information.
71 """
72
Brad Bishop6e60e8b2018-02-01 10:27:11 -050073 bb.utils.remove(e.data.getVar("CVE_CHECK_TMP_FILE"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -060074}
75
76addhandler cve_check_cleanup
77cve_check_cleanup[eventmask] = "bb.cooker.CookerExit"
78
79python cve_check_write_rootfs_manifest () {
80 """
81 Create CVE manifest when building an image
82 """
83
84 import shutil
85
Brad Bishopd7bf8c12018-02-25 22:55:05 -050086 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
87 deploy_file = os.path.join(d.getVar("CVE_CHECK_DIR"), d.getVar("PN"))
88 if os.path.exists(deploy_file):
89 bb.utils.remove(deploy_file)
90
Brad Bishop6e60e8b2018-02-01 10:27:11 -050091 if os.path.exists(d.getVar("CVE_CHECK_TMP_FILE")):
Patrick Williamsc0f7c042017-02-23 20:41:17 -060092 bb.note("Writing rootfs CVE manifest")
Brad Bishop6e60e8b2018-02-01 10:27:11 -050093 deploy_dir = d.getVar("DEPLOY_DIR_IMAGE")
94 link_name = d.getVar("IMAGE_LINK_NAME")
95 manifest_name = d.getVar("CVE_CHECK_MANIFEST")
96 cve_tmp_file = d.getVar("CVE_CHECK_TMP_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060097
98 shutil.copyfile(cve_tmp_file, manifest_name)
99
100 if manifest_name and os.path.exists(manifest_name):
101 manifest_link = os.path.join(deploy_dir, "%s.cve" % link_name)
102 # If we already have another manifest, update symlinks
103 if os.path.exists(os.path.realpath(manifest_link)):
104 os.remove(manifest_link)
105 os.symlink(os.path.basename(manifest_name), manifest_link)
106 bb.plain("Image CVE report stored in: %s" % manifest_name)
107}
108
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500109ROOTFS_POSTPROCESS_COMMAND_prepend = "${@'cve_check_write_rootfs_manifest; ' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500110do_rootfs[recrdeptask] += "${@'do_cve_check' if d.getVar('CVE_CHECK_CREATE_MANIFEST') == '1' else ''}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600111
112def get_patches_cves(d):
113 """
114 Get patches that solve CVEs using the "CVE: " tag.
115 """
116
117 import re
118
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500119 pn = d.getVar("PN")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600120 cve_match = re.compile("CVE:( CVE\-\d{4}\-\d+)+")
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500121
122 # Matches last CVE-1234-211432 in the file name, also if written
123 # with small letters. Not supporting multiple CVE id's in a single
124 # file name.
125 cve_file_name_match = re.compile(".*([Cc][Vv][Ee]\-\d{4}\-\d+)")
126
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600127 patched_cves = set()
128 bb.debug(2, "Looking for patches that solves CVEs for %s" % pn)
129 for url in src_patches(d):
130 patch_file = bb.fetch.decodeurl(url)[2]
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500131
132 # Check patch file name for CVE ID
133 fname_match = cve_file_name_match.search(patch_file)
134 if fname_match:
135 cve = fname_match.group(1).upper()
136 patched_cves.add(cve)
137 bb.debug(2, "Found CVE %s from patch file name %s" % (cve, patch_file))
138
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600139 with open(patch_file, "r", encoding="utf-8") as f:
140 try:
141 patch_text = f.read()
142 except UnicodeDecodeError:
143 bb.debug(1, "Failed to read patch %s using UTF-8 encoding"
144 " trying with iso8859-1" % patch_file)
145 f.close()
146 with open(patch_file, "r", encoding="iso8859-1") as f:
147 patch_text = f.read()
148
149 # Search for the "CVE: " line
150 match = cve_match.search(patch_text)
151 if match:
152 # Get only the CVEs without the "CVE: " tag
153 cves = patch_text[match.start()+5:match.end()]
154 for cve in cves.split():
155 bb.debug(2, "Patch %s solves %s" % (patch_file, cve))
156 patched_cves.add(cve)
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500157 elif not fname_match:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600158 bb.debug(2, "Patch %s doesn't solve CVEs" % patch_file)
159
160 return patched_cves
161
162def check_cves(d, patched_cves):
163 """
164 Run cve-check-tool looking for patched and unpatched CVEs.
165 """
166
167 import ast, csv, tempfile, subprocess, io
168
169 cves_patched = []
170 cves_unpatched = []
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500171 bpn = d.getVar("CVE_PRODUCT")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400172 # If this has been unset then we're not scanning for CVEs here (for example, image recipes)
173 if not bpn:
174 return ([], [])
175 pv = d.getVar("CVE_VERSION").split("+git")[0]
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600176 cves = " ".join(patched_cves)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500177 cve_db_dir = d.getVar("CVE_CHECK_DB_DIR")
178 cve_whitelist = ast.literal_eval(d.getVar("CVE_CHECK_CVE_WHITELIST"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600179 cve_cmd = "cve-check-tool"
180 cmd = [cve_cmd, "--no-html", "--csv", "--not-affected", "-t", "faux", "-d", cve_db_dir]
181
182 # If the recipe has been whitlisted we return empty lists
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 if d.getVar("PN") in d.getVar("CVE_CHECK_PN_WHITELIST").split():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600184 bb.note("Recipe has been whitelisted, skipping check")
185 return ([], [])
186
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600187 try:
188 # Write the faux CSV file to be used with cve-check-tool
189 fd, faux = tempfile.mkstemp(prefix="cve-faux-")
190 with os.fdopen(fd, "w") as f:
191 f.write("%s,%s,%s," % (bpn, pv, cves))
192 cmd.append(faux)
193
Brad Bishopd7bf8c12018-02-25 22:55:05 -0500194 output = subprocess.check_output(cmd).decode("utf-8")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600195 bb.debug(2, "Output of command %s:\n%s" % ("\n".join(cmd), output))
196 except subprocess.CalledProcessError as e:
197 bb.warn("Couldn't check for CVEs: %s (output %s)" % (e, e.output))
198 finally:
199 os.remove(faux)
200
201 for row in csv.reader(io.StringIO(output)):
202 # Third row has the unpatched CVEs
203 if row[2]:
204 for cve in row[2].split():
205 # Skip if the CVE has been whitlisted for the current version
206 if pv in cve_whitelist.get(cve,[]):
207 bb.note("%s-%s has been whitelisted for %s" % (bpn, pv, cve))
208 else:
209 cves_unpatched.append(cve)
210 bb.debug(2, "%s-%s is not patched for %s" % (bpn, pv, cve))
211 # Fourth row has patched CVEs
212 if row[3]:
213 for cve in row[3].split():
214 cves_patched.append(cve)
215 bb.debug(2, "%s-%s is patched for %s" % (bpn, pv, cve))
216
217 return (cves_patched, cves_unpatched)
218
219def get_cve_info(d, cves):
220 """
221 Get CVE information from the database used by cve-check-tool.
222
223 Unfortunately the only way to get CVE info is set the output to
224 html (hard to parse) or query directly the database.
225 """
226
227 try:
228 import sqlite3
229 except ImportError:
230 from pysqlite2 import dbapi2 as sqlite3
231
232 cve_data = {}
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500233 db_file = d.getVar("CVE_CHECK_DB_FILE")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600234 placeholder = ",".join("?" * len(cves))
235 query = "SELECT * FROM NVD WHERE id IN (%s)" % placeholder
236 conn = sqlite3.connect(db_file)
237 cur = conn.cursor()
238 for row in cur.execute(query, tuple(cves)):
239 cve_data[row[0]] = {}
240 cve_data[row[0]]["summary"] = row[1]
241 cve_data[row[0]]["score"] = row[2]
242 cve_data[row[0]]["modified"] = row[3]
243 cve_data[row[0]]["vector"] = row[4]
244 conn.close()
245
246 return cve_data
247
248def cve_write_data(d, patched, unpatched, cve_data):
249 """
250 Write CVE information in WORKDIR; and to CVE_CHECK_DIR, and
251 CVE manifest if enabled.
252 """
253
Brad Bishop316dfdd2018-06-25 12:45:53 -0400254 cve_file = d.getVar("CVE_CHECK_LOG")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600255 nvd_link = "https://web.nvd.nist.gov/view/vuln/detail?vulnId="
256 write_string = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500257 unpatched_cves = []
Brad Bishop316dfdd2018-06-25 12:45:53 -0400258 bb.utils.mkdirhier(os.path.dirname(cve_file))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600259
260 for cve in sorted(cve_data):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500261 write_string += "PACKAGE NAME: %s\n" % d.getVar("PN")
262 write_string += "PACKAGE VERSION: %s\n" % d.getVar("PV")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600263 write_string += "CVE: %s\n" % cve
264 if cve in patched:
265 write_string += "CVE STATUS: Patched\n"
266 else:
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500267 unpatched_cves.append(cve)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600268 write_string += "CVE STATUS: Unpatched\n"
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600269 write_string += "CVE SUMMARY: %s\n" % cve_data[cve]["summary"]
270 write_string += "CVSS v2 BASE SCORE: %s\n" % cve_data[cve]["score"]
271 write_string += "VECTOR: %s\n" % cve_data[cve]["vector"]
272 write_string += "MORE INFORMATION: %s%s\n\n" % (nvd_link, cve)
273
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500274 if unpatched_cves:
275 bb.warn("Found unpatched CVE (%s), for more information check %s" % (" ".join(unpatched_cves),cve_file))
276
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600277 with open(cve_file, "w") as f:
278 bb.note("Writing file %s with CVE information" % cve_file)
279 f.write(write_string)
280
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500281 if d.getVar("CVE_CHECK_COPY_FILES") == "1":
282 cve_dir = d.getVar("CVE_CHECK_DIR")
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600283 bb.utils.mkdirhier(cve_dir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500284 deploy_file = os.path.join(cve_dir, d.getVar("PN"))
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600285 with open(deploy_file, "w") as f:
286 f.write(write_string)
287
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500288 if d.getVar("CVE_CHECK_CREATE_MANIFEST") == "1":
289 with open(d.getVar("CVE_CHECK_TMP_FILE"), "a") as f:
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600290 f.write("%s" % write_string)