blob: 89ff970fcc0f5b848ff2e2dba69ae9ef7da63a92 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001# Handle U-Boot config for a machine
2#
3# The format to specify it, in the machine, is:
4#
5# UBOOT_CONFIG ??= <default>
Patrick Williamsc0f7c042017-02-23 20:41:17 -06006# UBOOT_CONFIG[foo] = "config,images,binary"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007#
8# or
9#
10# UBOOT_MACHINE = "config"
11#
12# Copyright 2013, 2014 (C) O.S. Systems Software LTDA.
13
Patrick Williamsc0f7c042017-02-23 20:41:17 -060014UBOOT_BINARY ?= "u-boot.${UBOOT_SUFFIX}"
15
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016python () {
Brad Bishop6e60e8b2018-02-01 10:27:11 -050017 ubootmachine = d.getVar("UBOOT_MACHINE")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 ubootconfigflags = d.getVarFlags('UBOOT_CONFIG')
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019 ubootbinary = d.getVar('UBOOT_BINARY')
20 ubootbinaries = d.getVar('UBOOT_BINARIES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021 # The "doc" varflag is special, we don't want to see it here
22 ubootconfigflags.pop('doc', None)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 ubootconfig = (d.getVar('UBOOT_CONFIG') or "").split()
Patrick Williamsc124f4f2015-09-15 14:41:29 -050024
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025 if not ubootmachine and not ubootconfig:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050026 PN = d.getVar("PN")
27 FILE = os.path.basename(d.getVar("FILE"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050028 bb.debug(1, "To build %s, see %s for instructions on \
29 setting up your machine config" % (PN, FILE))
Brad Bishop316dfdd2018-06-25 12:45:53 -040030 raise bb.parse.SkipRecipe("Either UBOOT_MACHINE or UBOOT_CONFIG must be set in the %s machine configuration." % d.getVar("MACHINE"))
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
Brad Bishopd7bf8c12018-02-25 22:55:05 -050032 if ubootmachine and ubootconfig:
Brad Bishop316dfdd2018-06-25 12:45:53 -040033 raise bb.parse.SkipRecipe("You cannot use UBOOT_MACHINE and UBOOT_CONFIG at the same time.")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
Patrick Williamsc0f7c042017-02-23 20:41:17 -060035 if ubootconfigflags and ubootbinaries:
Brad Bishop316dfdd2018-06-25 12:45:53 -040036 raise bb.parse.SkipRecipe("You cannot use UBOOT_BINARIES as it is internal to uboot_config.bbclass.")
Patrick Williamsc0f7c042017-02-23 20:41:17 -060037
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038 if len(ubootconfig) > 0:
39 for config in ubootconfig:
40 for f, v in ubootconfigflags.items():
41 if config == f:
42 items = v.split(',')
Patrick Williamsc0f7c042017-02-23 20:41:17 -060043 if items[0] and len(items) > 3:
Brad Bishop316dfdd2018-06-25 12:45:53 -040044 raise bb.parse.SkipRecipe('Only config,images,binary can be specified!')
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045 d.appendVar('UBOOT_MACHINE', ' ' + items[0])
46 # IMAGE_FSTYPES appending
47 if len(items) > 1 and items[1]:
48 bb.debug(1, "Appending '%s' to IMAGE_FSTYPES." % items[1])
49 d.appendVar('IMAGE_FSTYPES', ' ' + items[1])
Patrick Williamsc0f7c042017-02-23 20:41:17 -060050 if len(items) > 2 and items[2]:
51 bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % items[2])
52 d.appendVar('UBOOT_BINARIES', ' ' + items[2])
53 else:
54 bb.debug(1, "Appending '%s' to UBOOT_BINARIES." % ubootbinary)
55 d.appendVar('UBOOT_BINARIES', ' ' + ubootbinary)
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050057}